一聚教程网:一个值得你收藏的教程网站

最新下载

PHP configure: error: Cannot find ldap libraries in /usr/lib

时间:2012-12-17 00:00:00 编辑:简简单单 来源:转载

今天在CentOS 64位下编译安装PHP5.4.8。结果在configure的时候提示

首先来一个最常见的就是configure: error: libjpeg.(a|so) not found原因是我们大部分一些软件只要rpm -qa | grep ***

这时下面就有两个重复的的软件

[root@GFS_Server php-5.2.13]# rpm -qa | grep jpeg
libjpeg-6b-33
libjpeg-6b-33
libjpeg-devel-6b-33

32位和64位的都装了

configure: error: Cannot find ldap libraries in /usr/lib

提示在/usr/lib 下找不到相关模块,这是因为64位的linux默认把以上文件都存在 /usr/lib64 文件夹下。

解决方法:

 代码如下

cp -frp /usr/lib64/libldap* /usr/lib/

重新configure即可

 

文章评论

热门栏目