一聚教程网:一个值得你收藏的教程网站

解决Ubuntu 提示您可能需要运行apt-get update错误问题

时间:2014-12-19 00:00:00 编辑:简简单单 来源:转载

sudo apt-get update,会提示如下警告:

W: Duplicate sources.list entry http://archive.canonical.com/ubuntu/ precise/partner amd64 Packages (/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_precise_partner_binary-amd64_Packages)
W: Duplicate sources.list entry http://archive.canonical.com/ubuntu/ precise/partner i386 Packages (/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_precise_partner_binary-i386_Packages)
W: 您可能需要运行 apt-get update 来解决这些问题

解决方法:

进入/etc/apt/目录,将该目录下sources.list.d/及里面的内容全部删除,运行一下命令:

sudo rm -r /etc/apt/sources.list.d/

然后重新运行:

sudo apt-get update。

再次用apt-get安装软件就可以了,亲测成功


更新软件

然后您可以用 "apt-get upgrade" 更新所有有新版本的套件。不过如果您想看看那些套件会被更新,您可以加上 -s 选项执行一次upgrade:

apt-get -s upgrade

如果您想把整个系统由一个旧版本升级至新版本,您可能需要暂时忽略套件门的相依性问题,您可以先执行一次
 "apt-get dist-update"

apt-get dist-upgrade

没有问题后,您可以进行升级了。

apt-get upgrade

文章评论

热门栏目